Repository navigation
Upgrade node version (against CVE-2026-111497) - #61
Merged
cbeaudin-robotiq merged 2 commits intoOct 29, 2026
Merged
Conversation
mbegin-robotiq
approved these changes
Oct 29, 2026
mbegin-robotiq
left a comment
Contributor
There was a problem hiding this comment.
Approving: the check logic is correct. I ran isFixed against 20.19.0, 22.23.3/4, 22.24.0, 22.9.9, 23.0.0, 24.22.0/1, 26.12.1, 27.0.0, 22.23.4-rc.1 and 22.23, and every result was right; odd version strings are rejected. The inline threads are follow-ups, and the first two are worth doing before or soon after merge.
Note that CI hasn't run on this branch yet: the only run is in action_required and needs a maintainer to approve it.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Upgrade CI Node.js to 22 (CVE-2026-111497)
Why
CVE-2026-111497 ("Node2Shell") is a memory-corruption bug in the Brotli decoder bundled with Node.js. A crafted Brotli stream can corrupt memory in whatever process decompresses it. Our build decompresses remote content:
fetch()infetch-profile-readme.jsacceptsContent-Encoding: br. Node 20, which CI and deploy use today, never got a fix.What changed
New
.nvmrc(22): the single place that picks the Node release line for CI, deploy and local installs (nvm install/nvm use)..github/workflows/ci.ymlanddeploy.yml:node-version: 20is replaced bynode-version-file: .nvmrcwithcheck-latest: true, so every run uses the newest 22.x patch instead of whatever version is cached on the runner.New
scripts/check-node-version.js: fails unless the runtime is on a fixed release line at or above its first patched version:22.x ≥ 22.23.4
24.x ≥ 24.22.1
26.x ≥ 26.12.1
Every other line fails the check: Node 20, the end-of-life odd lines (23, 25), and any release line not in the list.
package.json:engines.nodegoes from>=20.0to^22.23.4 || ^24.22.1 || ^26.12.1, matching the check, so npm warns on install too.To move to a new release line: add its first fixed version to
FIXEDincheck-node-version.js, then updateenginesand.nvmrc.Testing
setup-noderesolves the latest 22.x from.nvmrc(see the step log)node scripts/check-node-version.jsexits 1 on a vulnerable Node version (e.g. 20.x)Reference
https://www.aikido.dev/blog/python-packages-vulnerable-node2shell-brotli-cve-2026-111497