You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
Alex Gavrishev (@anod) It would be good to upgrade the android build toolset we are using. I am not Java/Android expert, will this anyway change the minimum sdk version we correctly support, as I know few teams still needing support for Android 4.4 (sdk level 19) ?
Thanks Lalit Kumar Bhasin (@lalitb) I think there is no need to update minimum version. I will test and comeback with more details.
it might require to upgrade cmake, is there limitation for cmake version capabilities.
it might require to upgrade cmake, is there limitation for cmake version capabilities.
Which cmake version to upgrade to ? Ideally it would be good to support 3.1.0 as minimum version, and conditionally include any feature required from higher version:
Can I ask so that when we implement this, we can specify what versions of Android deps to use via env vars. My team needs this layer to be compatible with certain versions of NDK and SDK.. I wonder if we can use something like this:
For SDK level there is an option to overlay default config with custom tools.gradle.user file
I think app which depends on the lib upgrades a library defined target sdk, lowering target sdk can cause unpredictable behavior
Regarding NDK, There is a default NDK mapping between Gradle plugin and NDK
NDK version can be overridden via ANDROID_NDK_VERSION env variable
Regarding cmake, current version is 3.10, but there is a warning
CMake Warning at /Users/algavris/Library/Android/sdk/ndk/23.1.7779620/build/cmake/android-legacy.toolchain.cmake:416 (message):
An old version of CMake is being used that cannot automatically detect
compiler attributes. Compiler identification is being bypassed. Some
values may be wrong or missing. Update to CMake 3.19 or newer to use
CMake's built-in compiler identification.
Activity
lalitb commentedon Feb 9, 2023
Alex Gavrishev (@anod) It would be good to upgrade the android build toolset we are using. I am not Java/Android expert, will this anyway change the minimum sdk version we correctly support, as I know few teams still needing support for Android 4.4 (sdk level 19) ?
anod commentedon Feb 9, 2023
Thanks Lalit Kumar Bhasin (@lalitb) I think there is no need to update minimum version. I will test and comeback with more details.
it might require to upgrade cmake, is there limitation for cmake version capabilities.
lalitb commentedon Feb 9, 2023
Which cmake version to upgrade to ? Ideally it would be good to support 3.1.0 as minimum version, and conditionally include any feature required from higher version:
maxgolov commentedon Feb 16, 2023
Can I ask so that when we implement this, we can specify what versions of Android deps to use via env vars. My team needs this layer to be compatible with certain versions of NDK and SDK.. I wonder if we can use something like this:
or what not. Similar how it's handled in Unreal Engine. It's a moving target for us.
anod commentedon Feb 24, 2023
For SDK level there is an option to overlay default config with custom
tools.gradle.userfileI think app which depends on the lib upgrades a library defined target sdk, lowering target sdk can cause unpredictable behavior
Regarding NDK, There is a default NDK mapping between Gradle plugin and NDK
NDK version can be overridden via
ANDROID_NDK_VERSIONenv variableRegarding
cmake, current version is 3.10, but there is a warningBump Android externalNativeBuild CMake from 3.10.2 to 3.22.1 (#1468)