Repository navigation
Clear all open Dependabot security alerts - #606
Merged
Merged
Conversation
Python: uv kept vulnerable versions in the lockfiles for Python 3.9, because the patched releases don't support it. 3.9 is past end of life, so require 3.10, starting with the next Python release. Hold back two ruff type-hint rules that would otherwise rewrite published code. Site: refresh tailwindcss and sucrase, and override postcss and postcss-selector-parser. The built CSS is byte-identical to the live site. Kotlin JS: pin the packages that the JS test tooling uses, which never reach users, without a Kotlin upgrade that could affect them. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Resolves the 42 open Dependabot alerts. Nothing here changes published packages until the next release, and only the Python change affects users then.
Python (13 alerts)
A lockfile can hold several versions of one package, and uv kept vulnerable versions such as
pytest8.4.2 for Python 3.9, because the patched releases don't support it. That's also why Renovate keeps reopening #604 and #605, which should now become unnecessary.requires-pythonis now>=3.10, and 3.9 is removed from the CI matrix. Python 3.9 reached end of life in October 2025. Users on 3.9 keep 1.0.1, and this takes effect with the next Python release.UP007andUP035are ignored with a TODO, because the new minimum would otherwise makeruff checkrewrite 69 type hints in published code.ruffstays at 0.8.3.Docs site (6 alerts)
tailwindcssto 3.4.19 andsucraseto 3.35.1, which removes the oldglobandminimatch.overridesforpostcssandpostcss-selector-parser, avoiding anext16 upgrade.Kotlin JS (23 alerts)
jvm/build.gradlefor the packages used by Mocha, which runs the JS tests. Upgrading Kotlin instead could affect users.glob,minimatch,diff,serialize-javascript).Tested locally
./gradlew build --rerun-tasks --no-build-cachepasses, with all 102 tasks run. The JS tests ran on the new versions earlier (68 tests, no failures).pytestpasses on 3.10 and 3.12 in all three projects, andruff format --check,ruff check, andpyrightpass.npm auditreports 0 vulnerabilities, andnpm run buildsucceeds.braces3.0.3, whose advisory was withdrawn on 2026-10-23.Dependabot only re-scans the default branch, so the final count comes after merge.
🤖 Generated with Claude Code