Skip to content

fix(security): patch CVE-2026-111497 runtime and vulnerable dependencies - #55

Merged
Bas950 merged 3 commits into
mainfrom
security/cve-2026-111497-and-deps
Oct 26, 2026
Merged

Bas950 merged 3 commits into
mainfrom
security/cve-2026-111497-and-deps

Conversation

@Bas950

@Bas950 Bas950 commented Oct 26, 2026

Copy link
Copy Markdown
Contributor

Security fixes

Runtime (CVE-2026-111497, Brotli decoder out-of-bounds write, a.k.a. Node2Shell/HTTP2Shell)

  • CI test.yml used Node 16 (EOL, unpatched). Bumped to Node 24.22.1, which contains the fix. Tests pass on 24.22.1 with the same results as before (see below).
  • CI pnpm bumped 6.0.2 -> 8.15.9: pnpm 6 crashes on modern Node (ERR_INVALID_THIS), and the lockfile was regenerated by pnpm 8 (lockfile format 5.3 -> 6.0), so CI needs pnpm >= 8.

Dependencies (pnpm.overrides, same-major patched versions, lockfile regenerated with pnpm 8, not hand-edited)
minimatch 3.1.5, lodash 4.18.1, brace-expansion 1.1.21, braces 3.0.3, browserslist 4.29.4, js-yaml 3.15.2, picomatch 2.3.2 (these are the vulnerable packages reported as high/critical by osv-scanner).

Not fixed

  • @babel/traverse (CVE-2023-45133), semver 6.x/7.x, json5: the only listed fixed versions are in a different major line, or the installed major has no patch in the scan data; not forced to avoid breaking the toolchain (jest 28 / commitlint 16).

Verification

  • pnpm install + pnpm test on Node 24.22.1: 17/18 pass. The 1 failure (an invalid scope, expects no chore type) is pre-existing and identical on the base branch.

@Bas950
Bas950 merged commit 7eaa044 into main Oct 26, 2026
2 checks passed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant