Skip to content

Plugin fails to connect to GeoNode instances that require login (lockdown mode), even with valid credentials #343

Description

@meomancer

GeoNode instances are configured to require login for every page/request (LOCKDOWN_GEONODE=True). When connecting to this server, the plugin always shows the error "This GeoNode instance does not support the API client"
Even when I've entered valid credentials (tested in postman)

Expected behavior

Connection succeeds, since the credentials are valid.

Actual behavior

Immediate error: "This GeoNode instance does not support the API client", regardless of whether credentials are set.

Workaround that i do

Add this settings to exempt auth for api root
AUTH_EXEMPT_URLS = AUTH_EXEMPT_URLS + (r"^/api/v2/?$",)

Environment:

  • QGIS GeoNode plugin version: 2.1.0
  • QGIS version: 3.44.13-Solothurn
  • GeoNode version: 5.1.0
  • OS: Linux

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions